The Remote Application is not Able to Connect to Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

JIRA application cannot reach Confluence application when creating an application link between the two. An error message is shown:

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Diagnosis

Verify the connectivity between both servers. That can be done using the following methods:

Possible Causes

  1. Wrong Reciprocal Link URL. This is the url that the remote application (JIRA) uses to make the connection back to the local application (Confluence).

  2. Problem trying to reach out to the other server

  3. Blocked connection

Resolution

  • Contact your Network Administrator and perform network tests in order to see what connectivity errors (if any) are blocking the connection between both servers

  • Check the Reciprocal Link URL to see if it matches what the remote application has when performing the connection

Updated on April 8, 2025

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