Team Calendars seems to have an unidentified process kicking off a weekly job that overloads the application
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Every day or every week, around the same time, Team Calendars seems to have an unidentified process kicking off a weekly job that overloads the application and sometimes crashes the app
Environment
Confluence Server
Team Calendars
Diagnosis
On a scheduled basis, you notice Confluence running slower and crashing sometimes. In the logs, you can notice the following logs:
1
2
3
4
5
6
7
8
2020-10-07 15:24:11,590 WARN [http-nio-8090-exec-391] [analytics.client.listener.ProductEventListener] rejectedExecution Analytics event not be processed (most likely due to too many events in queue for single-threaded event processor).
– url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/6cea42815cedc59b6887d939b47e0faa38677b86.ics | traceId: 9a9e52cedb465609 | userName: anonymous
2020-10-07 15:24:11,592 WARN [http-nio-8090-exec-431] [analytics.client.listener.ProductEventListener] rejectedExecution Analytics event not be processed (most likely due to too many events in queue for single-threaded event processor).
– url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/6cea42815cedc59b6887d939b47e0faa38677b86.ics | traceId: fe079b26be0c69a0 | userName: anonymous
2020-10-07 15:24:11,598 WARN [http-nio-8090-exec-433] [analytics.client.listener.ProductEventListener] rejectedExecution Analytics event not be processed (most likely due to too many events in queue for single-threaded event processor).
– url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/6cea42815cedc59b6887d939b47e0faa38677b86.ics | traceId: 6fbba9fc956f0ebe | userName: anonymous
2020-10-07 15:24:11,600 DEBUG [http-nio-8090-exec-421] [extra.calendar3.calendarstore.AbstractCalendarDataStore] getSubCalendarContent Getting sub-calendar 2028534b-f0b2-48a3-98d5-3dbb958f4a61 events with ActiveObjects.
2020-10-07 15:47:49,317 ERROR [http-nio-8090-exec-430] [confluence.util.profiling.ProfilingSiteMeshFilter] doFilter Application context has not been initialized: – url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/6cea42815cedc59b6887d939b47e0faa38677b86.ics | traceId: eff2f7fc8bba4344 | userName: anonymous
Cause
Someone responsible for the calendar is forcing a refresh on a scheduled basis during work hours.
Solution
In the atlassian-confluence.log file, find the log entry similar to the one below:
1
2020-10-07 15:24:11,600 DEBUG [http-nio-8090-exec-421] [extra.calendar3.calendarstore.AbstractCalendarDataStore] getSubCalendarContent Getting sub-calendar 2028534b-f0b2-48a3-98d5-3dbb958f4a61 events with ActiveObjects.
Fetch the sub-calendar ID (that in the log above is 2028534b-f0b2-48a3-98d5-3dbb958f4a61) and run the following query against Confluence Database:
1
SELECT NAME FROM "AO_950DC3_TC_SUBCALS" WHERE "ID" = '2028534b-f0b2-48a3-98d5-3dbb958f4a61';
Based on the name of the Calendar, engage the respective owner to update their process/job, not during a business time, to avoid overloading your instance.
Was this helpful?