Team Calendars for Confluence's license type (null) is not the same as Confluence's license type (null)
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When entering Team Calendars for Confluence license into the license field, you'll get the error as per the screen shot:
Cause
The error message appears if your Confluence License Details page (http://<confluence-url>/admin/license.action) was showing a different SEN than your actual Confluence SEN number. The Team Calendars for Confluence license type and user count must match that of the Confluence license it is being used with. For example: Team Calendars for Confluence for Confluence 100 Users: Commercial License must be applied onto a Confluence 100 Users: Commercial License but not onto Confluence 10 Users: Starter License. This information ties on your SEN number. Hence, you'll get the above error when your Confluence license was showing a different SEN than your actual Confluence SEN number.
Resolution
Go to https://my.atlassian.com and double check on your Confluence SEN number. Ensure that the number matches the one you see from Confluence License Details page.
If it does not, go to https://my.atlassian.com and copy-paste/update the actual Confluence license again onto the license field in Confluence License Details page.
Next, copy-paste Team Calendars for Confluence license from https://my.atlassian.com into the Team Calendars for Confluence license field once again and the problem should be resolved.
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