Team Calendars for Confluence Performance Problems

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Confluence pages which contain Team Calendars for Confluence are slow to load.

Diagnosis

  1. Check external factors such as CPU utilisation, and memory allocation on the server to determine whether these are the root cause.

  2. If you use external calendar sources, check whether network slowness could be a contributing factor

  3. Enable Troubleshooting Slow Performance Using Page Request Profiling and reproduce the issue. Raise a support request and attach a Support Zip to it.

Cause

If there is no external cause and you're still experiencing slowness, it's likely due to a problem which was resolved in Team Calendars for Confluence 2.4. In previous versions, Team Calendars for Confluence collected statistics on calendar subsciptions on page loads, which was not necessary and has been removed. Performance has improved markedly as a result.

Solution

Resolution

  1. Upgrade Confluence to version 4.0 or above.

  2. Upgrade Team Calendars for Confluence to version 2.4 or above.

Updated on April 2, 2025

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