Team Calendars for Confluence displays 500 Error When using Export to iCalendar
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When using Team Calendars for Confluence built in function to Export to iCalendar, the export fails and a 500 Server Error is Displayed in the browser.
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Oops - an error has occurred
logo System Error
A system error has occurred — our apologies!
For immediate troubleshooting, consult our knowledge base for a solution.
If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:
a description of your problem and what you were doing at the time it occurred
a copy of the error and system information found below
a copy of the application logs (if possible).
Your Confluence administrator can use the support request form to create a support ticket which will include this information.
We will respond as promptly as possible.
Thank you!
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Cause
Stack Trace:hide
Referer URL https://xxxxxxx/calendar/mycalendar.action
The following appears in the atlassian-confluence.log
:
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2014-08-05 12:55:34,550 ERROR [http-8090-106] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service
– url: /rest/calendar-services/1.0/calendar/export/subcalendar/private/xxxxxxxxxxxxxx.ics | userName: <username>
javax.ws.rs.WebApplicationException: java.lang.NullPointerException
Cause
This issue normally occurs when an interruption of read and write permissions in the cache folder happens due to a connection issue or performance.
Workaround
Clearing the Plugins Cache will resolve this issue. You can clear the cache, by doing the following:
Shutdown Confluence
Ensure the user running Confluence has full read/write privileges to the confluence-home directory.
Remove the following directories
⚠️ This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup. However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.
<confluence-home>/bundled-plugins
<confluence-home>/plugins-cache
<confluence-home>/plugins-osgi-cache
<confluence-home>/plugins-temp
<confluence-home>/bundled-plugins_language
Start Confluence
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