Team Calendars for Confluence Cannot be Enabled Due to a ClassCastException Error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Team Calendars for Confluence, and possibly other plugins, may not be able to be enabled.
In the case of Team Calendars for Confluence, the following appears in the atlassian-confluence.log
:
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2014-11-03 17:10:46,890 ERROR [Spring executor 18] [extender.internal.activator.ContextLoaderListener] onOsgiApplicationEvent Application context refresh failed (NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.confluence.extra.team-calendars, config=osgibundle:/META-INF/spring/*.xml))
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'myWorkIntegration' defined in URL [bundle://165.0:0/META-INF/spring/spring-components.xml]: Invocation of init method failed; nested exception is java.lang.ClassCastException: com.atlassian.upm.license.internal.event.PluginLicenseEventPublisherImpl cannot be cast to com.atlassian.upm.api.license.PluginLicenseEventRegistry
Diagnosis
Check to see if the plugin "Atlassian Universal Plugin Manager - Plugin License Storage Plugin" is installed in the instance:
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Atlassian Universal Plugin Manager - Plugin License Storage plugin (com.atlassian.upm.plugin-license-storage-plugin, Version: 2.11, Installed: Oct 24, 2014)
Cause
Before version 2.0.1 of the UPM, a separate plugin was required to manage license functions for purchased addons. In later versions of the UPM, this functionality has been included, and this additional plugin is not required.
Additionally, it may be required to ensure that the UPM is at its latest version. See Updating the Universal Plugin Manager for more information.
Solution
Resolution
Uninstall or Disable the Plugin License Storage Plugin; and then try to enable Team Calendars for Confluence again.
If you're having difficulties removing Plugin License Storage Plugin plugin via the administration console, refer to our guide on How to manually remove malfunctioning apps (plugins) from Confluence Data Center
If you do remove it from the database, be sure to How to clear the apps (plugins) cache in Confluence Data Center before restarting Confluence
If you continue to have problems enabling Team Calendars for Confluence, please contact Atlassian Support
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