Team Calendar app is there but no Calendar is shown, and adding a calendar or any other action is not possible.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Team Calendar app is there but no Calendar is shown, and adding a calendar or any other action is not possible.

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Environment

Issue identified on Confluence Server and Data Center on version 7.13.7. It can happen on any Confluence using Team Calendars.

Diagnosis

No error is reported on User Interface.

When reproducing the issue with Developer Tools opened on the browser, it is possible to see an error like Uncaught Error: tc/subcalendar-menu-view missing tc/calendar-caldav-subscribe-model:

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Cause

It happens because one of the Calendar modules is disabled. In this case, Calendar Subscribe Dialog is the module disabled.

Solution

To fix this issue, it is necessary to enable the disabled module:

  1. Go to Cog Icon > Manage Apps

  2. From the dropdown menu, select “All Apps“

  3. Locate the App “Team Calendars” and expand it

  4. Expand “Team Calendars” modules

  5. Locate the disabled module. In this case Calendar Subscribe Dialog

  6. Click the “Enable“ button to enable it

Updated on March 13, 2025

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