Synchrony Service is not starting
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Synchrony service is not getting restarted and it is giving the following error in the logs:
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2022-09-28 12:45:57,805 ERROR [Caesium-1-3] [troubleshooting.healthcheck.concurrent.SupportHealthCheckProcess] lambda$getCompletedStatuses$0 Health check 'Collaborative Editing Mode' failed with severity 'major': 'Exception during health check invocation java.lang.IllegalStateException: Base URL misconfigured: <null>'
Environment
Confluence
Diagnosis
Synchrony service is not getting started and giving the following error in the logs:
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2022-09-28 12:45:57,805 ERROR [Caesium-1-3] [troubleshooting.healthcheck.concurrent.SupportHealthCheckProcess] lambda$getCompletedStatuses$0 Health check 'Collaborative Editing Mode' failed with severity 'major': 'Exception during health check invocation java.lang.IllegalStateException: Base URL misconfigured: <null>'
Also after checking the application.xml file, we could see the following property for the application base URL:
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<server.base.url>N/A</server.base.url>
Cause
Confluence Synchrony service is dependent on the Base URL, if the Confluence base URL is not configured correctly or missing in the general configuration page, then we can get this issue.
Solution
As per the logs, Confluence Base URL is not configured correctly. To fix this, we can follow the below steps:
Connect the Confluence General Configuration and try to set the correct Base URL.
If the base URL is configured, please try to re-update the same.
Once the base URL is updated, try to restart the Synchrony service from the Collaborative editing page.
If the above steps doesn't fix the issue, try to capture the Base URL detail from the DB ( Bandana Table ) and try to capture the base URL detail.
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select bandanavalue from bandana where bandanakey = 'atlassian.confluence.settings' ;
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