Subscriptions to iCal URLs of JustWorks applications into Team Calendars are failing
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
JustWorks applications allow the generation of an iCal URL, but, when you try to subscribe to it in a calendar of Team Calendars for Confluence, the following error will be triggered:
1
2
Error(s) occurred.
Unable to load events of Justworks (<id of the calendar>): calendar3.error.loadevents.notexist
The following actions trigger this error:
Navigate to a calendar and click on the drop-down arrow to select Subscribe by URL;
Add the Name, iCal URL and Related Space and click on the Subscribe button.
Cause
Team Calendars for Confluence does not process correctly the JustWorks iCal URL.
Workaround
Import into your calendar first the ICS file of the calendar you wish to subscribe to;
To create an ICS file from the iCal URL, you can enter in your browser the iCal URL followed by a .ics extension in the end.
An error will be thrown when you perform this action and you can cancel the import action;
Afterward, subscribe to the iCal URL;
The events of the calendar will be shown with the same error that was being triggered before;
If you wish to remove the error message shown, remove the subscription. Please note that this will prevent updates made to the events and new events added in the external calendar to be displayed.
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