Starting Confluence node fails with 'Port [5801] is already in use and auto-increment is disabled. Hazelcast cannot start' error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Attempting to start the second node in the same machine results in the following error found in the atlassian-confluence.log:

1 2 [com.hazelcast.instance.DefaultAddressPicker] log null [dev] [3.3-RC1-atlassian-1] Port [5801] is already in use and auto-increment is disabled. Hazelcast cannot start. java.net.BindException: Address already in use

Cause

Both nodes are using the same Hazelcast port

Resolution

  • Shutdown the second node

  • Add the following system property (See: Configuring System Properties):

    1 -Dconfluence.cluster.hazelcast.listenPort=5851
  • Startup Confluence again

Updated on April 15, 2025

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