Spaces are missing from the Space Directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Spaces are visible from the dashboard, but are not listed in the Space Directory. This has been known to happen after upgrading.

Cause

The content index and/or ancestor table are out-of-sync with the data in Confluence.

Resolution

  1. Rebuild the Content Index from scratch following the directions at How to Rebuild the Content Indexes From Scratch on Unclustered Confluence

  2. Rebuild the Ancestor Table from scratch following the directions at Rebuilding the Ancestor Table

Updated on April 8, 2025

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