Space or Global Activity History is Lost After Restoring Site XML Backup

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After performing an upgrade or a site XML import, the space or global activity history is missing.

Cause

The Usage Tracking (Activity and Global Activity) plugin stores the previous entries in the <confluence-home>\index\plugin directory. The missing index folder could lead to the global activity not showing.

Workaround

The only way to recover the data is from a backup of the index directory prior to any deletion.

Perform the following steps:

  1. Stop the Confluence instance

  2. Copy the <confluence-home>\index\plugin directory from the backup directory

  3. Place it back to the existing index directory

  4. Restart Confluence instance

  5. Re-build the content indexing via the Administration console

  6. Check if the previous data are being restored

Resolution

Track USGTRK-33 for a more robust storage mechanism.

Updated on April 8, 2025

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