'Some events were not shown in the calendars below because there were too many of them' error in Team Calendars for Confluence

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following error message appears in Team Calendars for Confluence:

Some events were not shown in the calendars below because there were too many of them

Cause

By default, it's 200 events per calendar. Note that this limit applies to all events in one calendar, and not just the events that are displayed on screen.

Resolution

Restrict the amount of events returned by the JQL query to less than 200 by using a time based filter such as: "created >= startOfDay(-60)"

If the query can't be modified, the system property "com.atlassian.confluence.extra.calendar3.display.events.calendar.maxpercalendar" can be configured to allow more events. See Configuring System Properties.

For example, add something like the following to the end of your JAVA_OPTS:

1 -Dcom.atlassian.confluence.extra.calendar3.display.events.calendar.maxpercalendar=300

In the event the above doesn't resolve the issue, you can check  Calendars aren't displayed due to invalid Time Zone, and apply its workaround if timezones are invalid.

Updated on April 8, 2025

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