Seeing userLink in the People Directory after upgrading Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Accounts in the People Directory show with #userLink($user). The following screen shot demonstrates what is seen:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

Search the <confluence install>//confluence/template/includes/macros.vm file for #userLink($user). If it does not exist in the file, please proceed with the Workaround.

Cause

Due to decorators and customizations, the macros.vm file was corrupted during the upgrade.

Solution

Workaround

  1. Backup your database and home directory

  2. Download a Confluence version that matches your current version from the archive

  3. We need to get the macros.vm file from that download. Please find that file in <confluence install>//confluence/template/includes/macros.vm and copy it somewhere that we can easily get to it

  4. Navigate to the same location on your current instance

  5. Take the macros.vm file and move it from this folder

  6. Move the macros.vm file that we recently downloaded, and place it in your folder

  7. Stop and restart the Confluence service

Updated on April 24, 2025

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