Search throws a System Error after upgrading Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When using the search functionality after upgrading Confluence the search will return a system error:

(Auto-migrated image: description temporarily unavailable)

The following appears in the atlassian-confluence.log:

1 2 3 4 5 6 2014-06-23 08:25:30,176 ERROR [http-bio-80-exec-629] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service: org.apache.lucene.search.FieldCache.getStrings(Lorg/apache/lucene/index/IndexReader;Ljava/lang/String;)[Ljava/lang/String; -- referer: http://wiki.pcmiracles.com/dashboard.action | url: /rest/quicknav/1/search | userName: john.hutson java.lang.NoSuchMethodError: org.apache.lucene.search.FieldCache.getStrings(Lorg/apache/lucene/index/IndexReader;Ljava/lang/String;)[Ljava/lang/String; at com.atlassian.confluence.plugins.awesomesearch.DocToEntityIdConverter.getEntityIdFromDoc(DocToEntityIdConverter.java:18) at com.atlassian.confluence.plugins.awesomesearch.UserHistoryBoostingStrategy.boost(UserHistoryBoostingStrategy.java:28) at com.atlassian.confluence.plugins.awesomesearch.UserHistoryBoostingStrategy.boost(UserHistoryBoostingStrategy.java:52)

Cause

This is caused because the Confluence Awesome Search plugin is not longer compatible with the upgraded Confluence version, to address this miss behaviour it's necessary to remove this third party plugin.

Resolution

  1. Go to manage Add ons page.

  2. Search and Uninstall the plugin "Confluence Awesome Search".

  3. Shutdown Confluence.

  4. Clear Confluence Plugin Cache

  5. Rebuild Confluence Content Indexes from Scratch

  6. Start Confluence.

  7. Try Searching again.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.