Search and dashboard load slowly - index timestamp is not updated due to file permissions
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
On Linux and Unix based systems, the following symptoms may occur:
Searches are very slow, therefore viewing the dashboard is very slow, but otherwise performance is okay.
The Index Queue sometimes contains too many entries and entries that are too old.
Cause
The Java method Confluence uses to set the last modified date on the .timestamp file sometimes fails if it is not running as the owner of the file, even when the user does have permission to edit the file.
Resolution
Delete the .timestamp file located in the <Confluence_Home>/index directory. CONF-9228 has additional information.
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