Resolve "Fontconfig head is null" Error in Confluence Data Center Sandbox

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

In Confluence Data Center, you might encounter issues uploading Office files for preview.

Diagnosis

The document conversion sandbox process crashes, preventing the file from being properly rendered or previewed in the Confluence UI.

Cause

In the application logs, the following error appears during sandbox initialization:

xxxx-xx-xx 14:27:05,386 INFO [document-conversion-sandbox-launcher-2] [impl.util.sandbox.ConversionSandbox] lambda$buildConfig$0 worker1: Caused by: java.lang.RuntimeException: Fontconfig head is null, check your fonts or fonts configuration

This indicates that the Java-based document conversion sandbox failed to initialise its font system due to a problem with the host system's underlying Fontconfig configuration.

Run the following command to list all fonts known to the system's Fontconfig library:

fc-list

If this returns no output or errors, Fontconfig can't detect system fonts, which will lead to sandbox initialisation failure.

Solution

To tackle this problem, a fontconfig (or an equivalent library) should be installed prior to Confluence installation. For further information about how to do this, refer to the documentation for your Linux distribution or preferred package manager.

Updated on May 23, 2025

Still need help?

The Atlassian Community is here for you.