Repeated addCounter Failed to add PDH Counter error messages on the logs

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After starting Confluence, these messages get logged repeatedly in short intervals, filling up the logs:

1 2020-06-19 13:34:31,804 WARN [diagnostics-os-thread] [util.platform.windows.PerfDataUtil] addCounter Failed to add PDH Counter: \Memory\Pages Input/sec, Error code: 0x800007D0

Environment

Confluence is running on a Windows environment.

Cause

These log entries are related to the Windows Performance Monitor tool, which the Confluence Diagnostic module uses in order to gather information from the operating system, to provide OS-related warning messages on the logs (such as low disk space, low free memory, etc). Error 0x800007D0 means the performance monitor tools could not be accessed by Confluence.

Solution

If the Confluence user (the user that's starting the Confluence service) can't access the OS's performance monitoring tools, that error will usually be displayed. The usual solution for these cases, is to add the service user which runs Confluence to the local group "Performance Monitor Users", as per the Resolution section of this article from Microsoft's documentation:

Updated on April 24, 2025

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