Removing Watches for a Deleted User
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
An undeliverable email is sent to a deleted user.
Cause
Proper deletion is done by dissociating a user from any can-use permissions. If a user has been removed from the database, their notifications may persist.
Resolution
Deactivate the user in your Confluence instance. If it doesn't help, you can manually remove notifications from the database by using the following SQL query:
For Confluence prior to release version 5.2.x
1
DELETE FROM NOTIFICATIONS WHERE username = '<user's name>';
For Confluence 5.2.x and above
1
DELETE FROM notifications WHERE username IN (SELECT user_key FROM user_mapping WHERE username= '<user's name>');
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