Questions for Confluence Popular content is missing after reindexing from scratch
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After following the steps at How to reindex from scratch on Data Center or How to reindex from scratch on Server the content from the "Popular" tab and/or "Popular Questions" in Questions for Confluence is missing.
Cause
For all versions of Confluence, the following files and folders may exist in the index
directories:
<confluence-home>/index/edge
It contains content such as the text of pages, blog posts, and comments
<confluence-home>/index/edge
this contains data about each change, such as when a page was last edited
<confluence-home>/index/edge
this is where popularity data for regular content is stored
<confluence-home>/index/plugin
this is where the Usage Tracking plugin stores the usage statistics
<confluence-home>/index/questions-edge
this is where Confluence Questions stores popularity data
ℹ️ Edge indexes are simply pointers to what is popular in the primary index. By clearing the edge index, Confluence must learn what is popular content again, which will take time to re-learn.
Solution
Restoring plugin indexes and popular content
If you need to restore the popular data from your backup:
Shut down Confluence
For each folder listed above that exists in your backup, restore it to the correct location
Restart Confluence
Rebuild Confluence Questions edge Index
First of all, remove the directory <confluence-home>/index/questions-edge
to rebuild these indexes from scratch.
Afterwards, you can reindex this content by submitting a POST to the following endpoint:
1
curl -k -I -u username:password -X POST --header "X-Atlassian-Token: no-check" https://<CONFLUENCE_BASE_URL>/rest/questions/1.0/admin/edges/reindex
ℹ️ You can also execute this request through the REST API browser. Be sure to uncheck the "Show only public APIs" box to reveal the endpoint.
⚠️ Please note that in a Data Center instance, that request will only rebuild the edge index on the node on which it's run. Additionally, the endpoint is a private API method and is subject change at any time without notice.
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