Progress Bar on Space Export Task Page Stuck When Confluence is Running Behind IIS Proxy
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
While performing Space Export, you will notice that the progress bar stuck and does not move.
The progress bar stuck, and the download button does not appear, while PDF export is created in <confluence-home>/temp
This issue may happen in other long running tasks such as deleting a space.
Diagnosis
Check if the export was actually successful by going to <confluence-home>/temp and see if the files are created.
Confluence is running behind an IIS proxy.
Open a Browser Console and monitor if the following error log appear when the progress bar stuck:
ReferenceError: getXmlHttp is not defined (dorflyingpdf.action)
Cause
Under Connection Timeouts in General Configuration, "Compress HTTP Responses" setting has been enabled.
Solution
Resolution
Uncheck "Compress HTTP Responses"
Go to Confluence Administrator > General Configuration
Click "Edit" button and uncheck the "Compress HTTP Responses"
Click Save button
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