Profile Picture Displayed as Question Mark to Anonymous User

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When your instance is set to public-anonymous accessible. An anonymous user is not able to see the correct profile picture of the user. It will be displayed as question mark as shown below:

(Auto-migrated image: description temporarily unavailable)

The right profile picture of the above should look like this instead:

(Auto-migrated image: description temporarily unavailable)

Cause

This is caused by the 'View User Profiles' permission of 'Anonymous Access' is disabled:

(Auto-migrated image: description temporarily unavailable)

Resolution

  1. Choose Browse > Confluence Admin.

  2. Click 'Global Permissions' in the left-hand panel.

  3. Click 'Edit Permissions'.

  4. In the 'Anonymous Access' section, select the 'View User Profiles' check box.

  5. Click 'Save All'.

    (Auto-migrated image: description temporarily unavailable)
Updated on April 15, 2025

Still need help?

The Atlassian Community is here for you.