Preferences and Admin Tabs Missing in the Plugin Repository Client

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The "Admin' and "Preferences" tab are no longer visible/availabe from the plugin repository client.

Cause

The "Data Source" configuration in the "Admin" tab of the repository client has been changed from Proxy Client to Local Generator but the Datasouce URL is still in the form suitable for ProxyDataSource, such as:

1 2 http://confluence.atlassian.com/plugin-repository/proxy.action?profile=confluence

Resolution

Run this query on your Confluence database:

select * from bandana where bandanakey like '%atlassian-plugin-repository%';

and look for a similar entry in the query results:

1 2 <dataSourceClassName>com.atlassian.plugin.repository.datasource.LocalDataSource</dataSourceClassName>

and update it as follows:

1 2 <dataSourceClassName>com.atlassian.plugin.repository.datasource.ProxyDataSource</dataSourceClassName>

to revert the changes back to using the proxy datasource.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.