Page Tree loads indefinitely after Upgrading Confluence to version 8.5.5 or later

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Confluence to the latest LTS version (8.5.5 or later), the Page Tree loads indefinitely without completing. 

Environment

Confluence 8.5.5 or later

Diagnosis

If there are any issues with the Page Tree system app modules due to the presence of the "Calendar Plugin", the following error entries will be present in the atlassian-confluence.log  files:

1 2 2024-04-08 15:28:20,913 ERROR [Catalina-utility-1] [atlassian.plugin.parsers.XmlDescriptorParserUtils] newModuleDescriptor There were problems loading the module 'extractor' in plugin 'Page Tree Plugin'. The module has been disabled. 2024-04-08 15:28:20,913 ERROR [Catalina-utility-1] [atlassian.plugin.parsers.XmlDescriptorParserUtils] newModuleDescriptor Cannot find ModuleDescriptor class for plugin of type 'extractor'.

Confirm that the Calendar Plugin is in the installed apps:

1 2 3 4 5 6 7 8 9 10 <plugin> <key>confluence.extra.calendar</key> <name>Calendar Plugin</name> <version>2.7.2.1</version> <vendor>Atlassian</vendor> <status>ENABLED</status> <vendor-url>http://www.atlassian.com/</vendor-url> <framework-version>1</framework-version> <bundled>User installed</bundled> </plugin>

Cause

The Page Tree is failing to load, possibly along with other UI components, due to security-related velocity changes introduced in Confluence 8.5.5. These changes were implemented in response to the security vulnerability identified in CONFSERVER-94064 which involved Remote Code Execution (RCE) in Confluence Data Center. As a result, certain old apps have ceased to function properly, affecting various aspects of Confluence's functionality.

Specifically, the Page Tree loading issue following the upgrade to Confluence 8.5.5 is attributed to an old Confluence app known as the "Calendar Plugin." This outdated app from Atlassian prevents the initialization of Confluence Page Tree system modules during startup, thereby causing the Page Tree loading problem.

Solution

To address this issue, it is recommended to disable or remove the Calendar Plugin from Confluence.

Additionally, restarting Confluence and clearing the plugin cache are required. Restarting Confluence ensures that any system app modules affected by the presence of the Calendar Plugin are properly initialized during startup.

Note: Other very old apps could also be causing the same issue. For example, the Snippet Plugin (com.atlassian.confluence.extra.snippet, Version: 2.0.2) might be a contributing factor.

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.