'Page Not Found' Error when Trying to Reach a Page Accessible to Other Users

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Get the following error:

1 The page you were trying to reach does not exist. You may want to try a search, or browse the site to find the page you were looking for.

When you click on a link to a page. The person who sent you the link can successfully open the page.

Cause

Confluence will throw this message in two circumstances.

  1. If the page actually doesn't exist.

  2. If you don't have permission to the page (it is against security practices to give an error message that you don't have permission to the page).

If another user is able to access the page, it is most likely that you do not have permission to access it.

Resolution

Ask another user with access to go to Tools >> Restrictions on the page and check if any viewing restrictions have been placed on the page. Also, have the other user go to Space Administration >> Permissions for that space and check to ensure you belong to a group that has permission to view pages in that space.

If you do not have access to Space Permissions, please request access from your Space Admin or Site Admin.

Updated on April 8, 2025

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