No Macro Metadata error when trying to insert JIRA Issue Macro

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

  • No Macro Metadata error when trying to insert a new JIRA macro in a page:

    (Auto-migrated image: description temporarily unavailable)
  • Confluence workbox notification

    (Auto-migrated image: description temporarily unavailable)

    dissappeared from the header menu

  • The JIRA Issue macro sidebar is missing when you try to insert the JIRA Issue macro in the page:

    (Auto-migrated image: description temporarily unavailable)

Diagnosis

  1. Check if the Workbox plugins are disabled, if yes, go to Resolution 1.

    1. Workbox - Common Plugin

    2. Workbox - Confluence Provider Plugin

    3. Workbox - Host Plugin

  2. Check if the In-app Notifications is disabled, if yes, go to Resolution 2.

  3. Ensure that there are no scripts in Confluence Admin >> Custom HTML. If there is please remove all code to eliminate the possibility of customization. If it is only occurring in specific Spaces, please try to check if there is any customization in those locations as well.

Cause

The cause of the issue is, the Workbox plugins or the In-app Notifications were disabled and that somehow was interfering with the JIRA Macros plugin. This issue is currently tracked in CONFSERVER-32861 - Insert JIRA Issues dialog missing sidebar or displaying "No Macro Metadata" error.

Solution

Resolution 1

If the Workbox plugins are disabled, please enable the plugins following the sequence below

  1. Enable the Notifications and Tasks - Common Plugin

  2. Enable the Notifications and Tasks - Host Plugin

  3. Enable the Notifications and Tasks - Confluence Provider Plugin

Resolution 2

Enable the In-app Notifications in Admin > In-app Notifications.

Resolution 3

Only try this resolution if the other two resolutions above does not solve the issue.

Please backup your database dump before performing the step below.

  1. Shutdown Confluence.

  2. Run the query to verify, if it return you a result, please proceed on step 3

    1 SELECT * FROM BANDANA WHERE BANDANAKEY ='com.atlassian.mywork.target';
  3. Run the query below to delete the entry:

    1 DELETE FROM BANDANA WHERE BANDANAKEY ='com.atlassian.mywork.target';
  4. Clear Plugin Cache.

  5. Restart Confluence.

Updated on April 8, 2025

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