New users are not able to access Confluence due to larger groups breaking the sync for the user base
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
New users are not able to access Confluence even though they have product access configured and are already added to existing permissions or memberships that grant permission to view content.
Diagnosis
When a new user tries to access Confluence, a "Too many redirects" error will be displayed by the browser.
After reloading the error page, a message stating that "we're almost there" is displayed:
Finally, if the user is able to access Confluence, not content is displayed on the home page, or upon trying to access spaces, a permission error message is displayed. For example:
Cause
This issue happens when there are groups on the site that are exceeding the 255 character limit, breaking the sync for new users to join Confluence. Although the creation of groups does not allow it to be exceeded, if the group is retrieved via user provisioning, there will have no character limit. There is a suggestion in place to change this behavior:
Solution
To start with the resolution, identify larger groups via the User management session of the instance via https://admin.atlassian.com. To make it faster, these groups can be identified via a user export.
Once the larger groups are identified, as an organization administrator that has access to the identity provider configured to use user provisioning, remove these groups to be synced to Atlassian and then, delete the group from the User Management session to not have it displayed anymore.
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