Multicast communication works only one-way
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Testing multicast connectivity (example tool: http://download.oracle.com/otn/java/coherence/coherence-331.zip) results in one of the nodes successfully receiving multicast messages, while the other(s) fail to.
Diagnosis
Setting the multicast group address between 224.0.0.1 and 224.0.1.0 will make the connectivity work, but addresses outside this range fail to work.
Cause
Some routers/network elements filter globally-scoped multicast addresses, but let the reserved range through.
Workaround
Use the reserved range, however this may be more polluted in various networks or not available. Please contact your network administrators on picking the range.
Resolution
Allow multicast traffic on the desired range/address, contact your network administrators.
Was this helpful?