Missing People in Confluence People Directory

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

There are users missing from the Confluence People Directory.

Diagnosis

Though the users have Confluence Access and are able to login to Confluence, they do not show in the Confluence People Directory.

The users should show up when they are created and have been added to the confluence-users group.

In Confluence Cloud, the people directory does not include users who have been permitted access to Confluence in User Management if they have never logged in.

In Confluence Server, when using External User Management, this also does not include users who have been permitted access but never logged in.

Cause 1:

Confluence content indexing has been corrupted

Cause 2:

The user metadata has not been upgraded correctly.

Workaround

Workaround 1:

As an admin of your server instance:

  1. Rebuilding the search index and see if this has solved the issue. If users still do not appear in people directory, try:

  2. Rebuild the content indexes from scratch

Workaround 2:

As an Administrator of your Server instance:

  1. Open this URL in your browser: <Confluence Address>/admin/force-upgrade.action

  2. Select userIndexingUpgradeTask in the *Upgrade task to run* dropdown list.

  3. Choose Force Upgrade.

For Cloud instances:

  1. Browse directly to the missing user's profile address by following the pattern: https://[instancename].atlassian.net/wiki/display/~[username]

  2. The user's entry will have been generated.

Updated on April 8, 2025

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