Message "Ouch! We can't load the PDF" exhibited when trying to open PDFs on a page after user session timeout
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
PDF attachment is no longer viewable after a user who has timed out (but did not know they were timed out) clicks on the PDF attachment to view it. The message "Ouch! We can't load the PDF" is exhibited:
Environment
Confluence 6.14.2
Diagnosis
A user is logged on Confluence and is viewing a page with PDF attachments for a period long enough that the session timed out.
If that user tries to click on the PDF file to view it, the file won't open, displaying the error in the screenshot above.
Other users that recently logged in are able to open the file without problems.
Trying to re-login, restart Confluence, or restarting the browser doesn't solve the issue.
Cause
Still unknown.
Solution
Clearing the browser's cache.
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