Long Running Event on Team Calendars for Confluence leads to 500 - GC overhead limit exceed/"Internal Server Error"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When Confluence try to load calendars on My Calendar page, Confluence would take a long time to load it and lead to 500 - GC overhead limit exceed on Team Calendars for Confluence 1.8.2 and prior it, while on Team Calendars for Confluence 1.9 Internal Server Error will be thrown on the UI level. Usually this is caused by user incorrectly configured the end date of event(s)

Here are the screenshots and the stack trace thrown in atlassian-confluence.log:

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Team Calendars for Confluence Prior to 1.9

1 2 3 ERROR [http-8357-1] [opensymphony.xwork.util.CompoundRootAccessor] getProperty Caught an Ognl exception while getting property calendarHtml -- url: /confluence/calendar/mycalendar.action | userName: admin | referer: http://localhost:8357/confluence/dashboard.action | action: mycalendar ognl.OgnlException: calendarHtml [java.lang.OutOfMemoryError: GC overhead limit exceeded]
(Auto-migrated image: description temporarily unavailable)

Team Calendars for Confluence 1.9 and above

1 2 2012-04-02 18:08:24,054 ERROR [http-8414-5] [[Standalone].[localhost].[/confluence].[noop]] log Servlet.service() for servlet noop threw exception java.lang.OutOfMemoryError: Java heap space

Cause

A very long running event cause such behavior in Confluence

Diagnosis and Resolution

When such symptom occurred run the following diagnostic steps

  1. Execute the following SQL query into your Confluence database

    1 SELECT * FROM bandana WHERE BANDANACONTEXT LIKE '%CALENDAR_%' AND BANDANAVALUE LIKE '<string>BEGIN:%';

    The above query would return all the ICS file of the installed calendar

  2. Try to find following DTSTART and DTEND parameter on every event on each ICS

    Example:

    1 2 DTSTART;VALUE=DATE:20120203&#x0D; DTEND;VALUE=DATE:20120204&#x0D;

    The above lines means that the event configured to run from 3rd of February, 2012

  3. Try to find the long running event that may cause this issue. For example:

    1 2 DTSTART;VALUE=DATE:20120202&#x0D; DTEND;VALUE=DATE:29990203&#x0D;

    The above parameter stated that the event run from February 2012 to February 2999

  4. Modified the year of the date end correctly in shutdown mode

  5. Restart Confluence

Updated on April 11, 2025

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