Login Fails When Using JIRA for User Management Due To SQL Server Configuration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users are unable to log in after delegating user management to JIRA. The following appears in the atlassian-confluence.log:

1 2 3 4 2008-06-06 11:54:55,005 FATAL [http-8080-Processor3] [user.provider.jdbc.JDBCCredentialsProvider] handles Could not see if [admin] is handled java.sql.SQLException: Invalid object name 'userbase'. at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)

Cause

This is a unique error due to the JIRA database using the schema 'jira'.

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.