Login Fails When Using JIRA for User Management Due To SQL Server Configuration
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Users are unable to log in after delegating user management to JIRA. The following appears in the atlassian-confluence.log:
2008-06-06 11:54:55,005 FATAL [http-8080-Processor3] [user.provider.jdbc.JDBCCredentialsProvider] handles Could not see if [admin] is handled
java.sql.SQLException: Invalid object name 'userbase'.
at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:368)
Cause
This is a unique error due to the JIRA database using the schema 'jira'.
Resolution
Warning: Backup your database before proceeding.
This article describes how to run SQL UPDATE statements directly against the Confluence database to replace hard-coded links. UPDATE statements are not reversible — any mistake will modify your live data permanently. Before running any SQL in this article, create a full backup of your Confluence database. Test the queries in a staging environment first if possible.
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