Login Fails After Upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Login fails after an upgrade. The following message appears in the logs:
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java.lang.NoClassDefFoundError: org/apache/log4j/PatternLayout
Cause
Confluence is missing the class "org/apache/log4j/PatternLayout.class," which is a part of log4j library jar file.
Resolution
Move the log4j.jar file from the WEB-INF/lib directory to the /common/lib (Tomcat 5.5) or /lib (Tomcat 6) directory.
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