Loading a Confluence page throws 'net::ERR_HTTP2_PROTOCOL_ERROR' in the browser Developer Tools

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Some Confluence pages are not loading or loading partially, and the error net::ERR_HTTP2_PROTOCOL_ERROR is thrown in the browser developer tool.

Ocasionally, if your Confluence page runs a Javascript code inside HTML macros, they might not work properly or not load at all.

Cause

Some browsers check the accuracy of transmitted data via the headers, and if there's an inconsistency (which compression can sometimes cause), it will return a failure.

Solution

Please, check if HTTP compression is enabled in your Confluence instance: .

  • Browse to General Configuration and find the section "Connection Timeouts"

  • Check the value of "Compress HTTP Responses"

If it's enabled, please disable it and check if this affects the behavior, if the errors change or remain the same.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.