Lightweight Task List mail notification is not received when using Exchange 2007 SMTP server

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

You have the lightweight Task List configured in Confluence page however when you assigned a task to a user, no email notification is received and it got stucked in the Mail Queue (checked from http://<confluence-url>/admin/mail/viewmailqueue.action page). All other mail notification is working fine.

Cause

Exchange server does not have relay enabled for Confluence server.

Resolution

Enable relay for Confluence server in Exchange server.

Updated on April 8, 2025

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