LDAP Users are Unable to Login After Upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users are not able to log in to Confluence but are able to sign up for a new Confluence account.

Cause

User management was configured for LDAP with authentication in a previous version. The configuration files are no longer in place after the upgrade.

Resolution

Copy the osuser.xml file from the previous version of Confluence over to the later version of Confluence.

Updated on April 8, 2025

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