Layout problems due to cookie size after installation Third Party SSO plugin

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Browsing through the UI after installing third-party SAML SSO for Confluence display problem will be visible.

Environment

Confluence with SAML SSO for Confluence

Diagnosis

Checking the HAR file 400 Bad Request HTTP errors will be visible.

If you receive this error frequently, the best thing to do is to delete the Cookies for that particular domain.

Let us say, if you are receiving this error when you visit any page on say, example.com, then you should delete all the Cookies of example.com from your browser’s cache.

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Cause

Header size is too big for certain requests. Increasing the value on Tomcat should help in this case.

Solution

Resolution

Increase or add "maxHttpHeaderSize" size to "32768" in used connector in the <Conflence-install>/conf/server.xml like this:

From

1 <Connector port="8090" connectionTimeout="20000" maxThreads="200" minSpareThreads="10" enableLookups="false" acceptCount="10" URIEncoding="UTF-8" />

To

1 <Connector port="8090" connectionTimeout="20000" maxThreads="200" minSpareThreads="10" enableLookups="false" acceptCount="10" URIEncoding="UTF-8" maxHttpHeaderSize="32768"/>
Updated on April 8, 2025

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