Jira Macro Filter displays no issues in Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The following appears in the page:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

This issue happens when you add a Jira issue and you can't view it in Confluence.

Cause

It happens when the following parameters are in jira-config.properties or jpm.xml:

1 2 jira.search.views.max.limit = -1 jira.search.views.default.max = -1

Solution

Resolution

  • Shutdown Jira

  • Open the jira-config.properties file (located at the root of your JIRA Home Directory) in a text editor.

    ⚠️ This file may not exist if you are using a new Jira installation or an upgraded Jira installation where your previous Jira version(s) had never been customized.

  • If you don't have jira-config.properties file, you need to open JIRA jpm.xml file which is located at <jira-application-dir>/WEB-INF/classes/Advanced JIRA Configuration

  • Find for the following parameter in the file

    1 2 jira.search.views.max.limit = -1 jira.search.views.default.max = -1

    and change it to

    1 2 jira.search.views.max.limit = 1000 jira.search.views.default.max = 1000
  • Save the file

  • Restart Jira

ℹ️ For more information read Limiting the number of issues returned from a search view such as an RSS feed.

Updated on April 2, 2025

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