JIRA link appears as unknown characters in Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When Confluence's language is changed to a supported language, the number of JIRA links on the top of the page might be translated to unknown characters.

(Auto-migrated image: description temporarily unavailable)

This is caused by an encoding issue with the JIRA environment.

Diagnosis

  • If this is the case, first check to see if the language pack used has actually translated the link above.

  • If it is, check the JIRA System info page and see if the System encoding is using Cp1251 instead of UTF8.

Environment

  • This issue is most likely to occur on Windows, since that is the default encoding.

Resolution

  • Add the "-Dfile.encoding=utf-8" property by default to the Jira Startup options.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.