JIRA Issues Macro Search Does Not Work in IE9

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Using IE9, when trying to search for a JIRA issue to insert into a JIRA Issues Macro, an error is thrown: "Received the following HTTP error code from the server: 200"

(Auto-migrated image: description temporarily unavailable)

However, network logs shows a "304" redirect. No errors are thrown in the application logs.

Cause

Cookies are missing from the header.

Resolution

  • In IE, allow cookies for Confluence at Tools > Internet Options > Privacy > Sites > Address of website, add the Confluence url, and click Allow.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.