JIRA Issues Macro: $exceptionMessage displays on page in Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

JIRA issues macro is showing error '$exceptionMessage' for some users.

Cause

After moving Confluence from Atlassian Cloud to a Atlassian Server environment, there is a corruption to the OAuth tokens being used in the database.

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Backup the Confluence database.

  2. Delete the existing application link.

  3. Shutdown Confluence.

  4. Run the following query on the Confluence database:

    1 DELETE FROM BANDANA WHERE BANDANAKEY LIKE '%oauth%';
  5. Start Confluence.

  6. Recreate the application link.

  7. Verify that the application link is working properly for users.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.