Jira Issue/Filter not working - The Jira server didn't understand your seach query

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When searching for a Jira Issue or Project, using the Jira Issue/Filter macro in Confluence, the following message is displayed:

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The user has the proper permissions to see issues on Jira - whether using OAuth or OAuth (with impersonation).

Diagnosis

  1. Increase the logging level, in Confluence, for class org.apache.http (set to DEBUG)

  2. Using the Jira Issue/Filter macro, try to search for a Jira Project or Issue

  3. Search through Confluence application logs to see the request performed to Jira:

    atlassian-confluence.log

    1 2020-07-30 16:24:14,464 DEBUG [http-nio-6761-exec-6] [org.apache.http.wire] wire http-outgoing-182 >> "GET <JIRA_BASE_URL>/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project%20%3D%20DRAG&returnMax=true&tempMax=20&field=summary&field=type&field=link&_=1596137041769 HTTP/1.1[\r][\n]"
  4. Observe that the request is failing with a HTTP 400 error (Bad Request)

    atlassian-confluence.log

    1 2020-07-30 16:24:14,483 DEBUG [http-nio-6761-exec-6] [org.apache.http.wire] wire http-outgoing-182 << "<!doctype html><html lang="en"><head><title>HTTP Status 400 [0xe2][0x80][0x93] Bad Request</title><style type="text/css">h1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} h2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} h3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} body {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} b {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} p {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;} a {color:black;} a.name {color:black;} .line {height:1px;background-color:#525D76;border:none;}</style></head><body><h1>HTTP Status 400 [0xe2][0x80][0x93] Bad Request</h1><hr class="line" /><p><b>Type</b> Status Report</p><p><b>Message</b> Could not find any enabled plugin with key jira.issueviews:searchrequest-xml</p><p><b>Description</b> The server cannot or will not process the request due to something that is perceived to be a client error (e.g., malformed request syntax, invalid request message framing, or deceptive request routing).</p><hr class="line" /><h3>Apache Tomcat/8.5.42</h3></body></html>"

Cause

The Jira Issue/Filter macro relies on the Issue Views Plugin, on Jira - more specifically, on its XML (searchrequest-xml) module.

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If either the Issue Views Plugin or the XML (searchrequest-xml) is disabled for some reason, the search requests from Confluence will fail.

Solution

  1. In Jira, go to

    (Auto-migrated image: description temporarily unavailable)

    > Manage apps

  2. Filter by System Apps

  3. Scroll down to find Issue Views Plugin

  4. Enable the Issue Views Plugin - or the XML (searchrequest-xml) module

Updated on April 8, 2025

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