JavaScript Errors on Internet Explorer 8

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This documentation will only applies to Confluence prior to version 5.6.x as IE8 has been deprecated in said version. See list of "End of support announcements" from Confluence 5.6 Upgrade Notes.

Symptoms

After upgrading JavaScript, the users can see JavaScript errors on Internet Explorer 8. It appears on the dashboard page even before logging on. See an example of JavaScript errors regarding IE 8:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

In order to confirm if you're experiencing the error mentioned above, please, check the following points:

  • Check if the proxy configuration is the same for the users that are experiencing these errors.

  • Set all Internet Explorer security levels to the same level for everyone.

  • Also, check if there is no Trusted Sites on Internet Explorer 8, they have different security levels from the other sites.

  • Default the user customization(s).

Cause

The pages experiencing JavaScript error is due security level constraints set on Internet Explorer 8 being different from default.

Solution

Resolution

  1. Change all pages experiencing JS errors to the default security level ("Medium").

  2. If Trusted Sites is the case, remove the page list of trusted sites, so it will show up as part of the "Internet" zone (with "Medium-high" security level).

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.