java.lang.ClassCastException com.atlassian.confluence.setup.settings.GlobalDescription cannot be cast to com.atlassian.confluence.pages.AbstractPage Due to Missing Global Logo

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Log files quickly fill with exceptions like:

1 2 3 4 Sep 28, 2009 11:23:59 PM org.apache.catalina.core.StandardWrapperValve invoke SEVERE: Servlet.service() for servlet action threw exception java.lang.ClassCastException: com.atlassian.confluence.setup.settings.GlobalDescription cannot be cast to com.atlassian.confluence.pages.AbstractPage at com.atlassian.confluence.spaces.DefaultSpaceManager.getSpaceFromPageId(DefaultSpaceManager.java:599)

Cause

The Global Logo is not set correctly or is inaccessible.

Resolution

Try toggling the Global Logo off and then on again, then if necessary re-uploading it from Administration >> Global Logo. See Changing the Site Logo.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.