How to fix the backup error with depreciated contents of USERSTATUS.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Unable to perform XML backup and getting the following error message in the atlassian-confluence.log:

1 2 3 2020-02-18 14:00:52,792 ERROR [http-nio-8090-exec-14] [confluence.importexport.impl.AbstractXmlExporter] backupEntities Couldn't backup database data. – referer: https://confluence.com/admin/backup.action | url: /admin/dobackup.action | ... | action: dobackup org.hibernate.WrongClassException: Object [id=12345] was not of the specified subclass [com.atlassian.confluence.core.ContentEntityObject] : Discriminator: USERSTATUS

Diagnosis

Check if there are contents with the type USERSTATUS by using the following SQL query:

1 SELECT contentid from CONTENT where contenttype='USERSTATUS';

The result of the SQL query above should include the offending object id mentioned in the error message that you have.

Cause

This error is happening due to the depreciated content type of USERSTATUS, and it needs to be deleted from the database manually to fix the issue. USERSTATUS has been deprecated since Confluence 5.8.9.

Solution

Delete the content from the database and fix the issue with the below steps:

  1. Stop Confluence

  2. Take a full backup of DB

  3. Delete the content:

    1 2 DELETE from CONTENT_LABEL where contentid = (SELECT contentid from CONTENT where contenttype='USERSTATUS'); DELETE from CONTENT where contentid = (SELECT contentid from CONTENT where contenttype='USERSTATUS');

    ⚠️ Please always backup your database before performing any alteration in the database side.

  4. Restart Confluence

  5. Reindex Confluence by going to General Configuration > Content Indexing > Rebuild Index

Updated on April 8, 2025

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