HAR file captures ERR_HTTP2_PING_FAILED
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
During various actions in Confluence, the following error is captured in HAR file.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
"startedDateTime": "2020-05-01T04:35:34.348Z",
"time": 78.40789100003894,
"request": {
"method": "POST",
"url": "http://localhost:8090/",
"httpVersion": ""
.
.
"response": {
"status": 0,
"statusText": "",
"httpVersion": "",
"headers": [],
"cookies": [],
"content": {
"size": 0,
"mimeType": "x-unknown"
},
"redirectURL": "",
"headersSize": -1,
"bodySize": -1,
"_transferSize": 0,
"_error": "net::ERR_HTTP2_PING_FAILED"
Environment
Usually a reverse proxy like NetScaler is involved, though can happen in case of any middle-ware devices while accessing Confluence.
Diagnosis
In HAR file check if the httpVersion is missing. If it's the case, reverse proxy needs to be reconfigured so it is passing proper httpVersion headers.
Was this helpful?