Global Configuration Settings Are Lost

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Altering global settings such as the Max size of an attachment, Server Base URL, or other global settings appear to be set correctly on alteration. However, upon restart of the application, the custom configurations revert to the default (such as 10MB for the max size of attachments and 5 for max number of uploads at one time).

Diagnosis

Check the bandana table for duplicate rows:

1 select bandanavalue from bandana where bandanakey = 'atlassian.confluence.settings';

There is a second cause to this issue that tends to happen more often in a cluster (Confluence 5.4 and earlier), but Atlassian has not yet diagnosed it. If there are no duplicate entries and your global settings are reverting, please help us diagnose the problem. Our current theory is that a null value in the cache is corrupting the values. Enable logging by adding the following values to log4j.properties: log4j.logger.com.atlassian.confluence.setup.bandana=DEBUG, confluencelog log4j.additivity.com.atlassian.confluence.setup.bandana=false

Cause

Because there are two rows for the settings, one row is being updated when updates are made and the other row (holding the default values) is being loaded in during a restart of the application. This behaviour generally shows up after upgrading.

Solution

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

Delete the row in the database that contains the default values. See the diagnosis section above.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.