Resolve "We've hit a snag!" error message when viewing Confluence pages

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

When accessing Confluence pages, a "We've hit a snag!" message is displayed with different codes:

image of "we've hit a snag" error message in Confluence

Diagnosis

  • Check if this is happening with all Confluence pages.

  • Check if Confluence can be accessed at its home page (https://yoursite.atlassian.net/wiki).

  • Check if using a different browser will display the pages.

Cause

There are multiple causes for this error:

  • Configurations for the browser (i.e., cache, extensions, version).

  • The user is accessing the pages via links and does not have permission to access Confluence or the affected pages.

  • There is an error with the page's content (i.e., A page is not displayed due to duplicate calendars).

Solution

For each of the scenarios, different procedures can be tried to fix it:

  • Browser troubleshooting:

    • Clear the browser's cache to ensure no corrupted cache blocks content viewing.

    • Ensure the browser is on its latest version to be compatible with the Cloud environment.

    • Make sure that no cookies are blocked for the Confluence instance.

    • Disable browser extensions to ensure they don't block the content (i.e., some JavaScript that would render the page).

    • Try to run the browser in incognito mode to check if it will render the content.

  • Permission troubleshooting:

    • Engage a site admin to check if the user has access to Confluence (via the User management of the instance).

    • If the access is granted to Confluence, engage a space administrator to check if the user can view the space (i.e., the groups the user belongs to or individual space access).

  • Content troubleshooting:

    • Unsupported macros or content on the page could also cause this issue.

    • A quick way to identify would be to create a copy of the page to check the content.

    • Select (...) on the page tree in the left navigation to create a copy.

ℹ️ If none of the troubleshooting helps, this can indicate that the specific page's content has issues. To understand what can be causing it, contact Atlassian support.

Updated on May 14, 2025

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