Getting HTTP Error 403 when Connecting to Crowd

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

1 2 2010-10-25 23:38:01,564 ERROR [DefaultQuartzScheduler_Worker-6] [bucket.user.DefaultUserAccessor] getUser Error in getUser():org.codehaus.xfire.XFireRuntimeException: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Server returned error code = 403 for URI : http://crowdURL:8091/crowd/services/SecurityServer. Check server logs for details com.atlassian.user.EntityException: org.codehaus.xfire.XFireRuntimeException: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Server returned error code = 403 for URI : http://crowdURL:8091/crowd/services/SecurityServer. Check server logs for details

Cause

Crowd is behind a firewall.

Resolution

  1. Fix your proxy rule as to allow Confluence server to connect to your Crowd's one. Note that this can also affect you even if Crowd and Confluence are hosted in the same server (a case where localhost is blocked by your firewall).

  2. Check your outbound proxy.

Updated on April 8, 2025

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