German Umlaut is not rendered correctly in Quick Search
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
When typing a German Umlaut (like höher) in Quick Search, the umlaut character is translated to another symbol, for example: h�her
See sample screen shot:

Diagnosis
Temporarily enable Plugin Safe Mode and see if it makes any difference. This will disabled all user-installed plugins at once. So if the issue does not occur again, it is caused by one of the third-party plugins installed. This may need to be done during non-peak hours as disabling third-party plugins would cause users unable to perform some operations provided by those plugins. Once the test has been carried out, disable this mode.
Check on the followings against your Confluence setting and see if it is already set to utf-8 or otherwise:
Cause
This is caused by RefinedWiki Theme
Solution
Resolution
Upgrade the plugin to the latest version that is compatible with your Confluence version. If problem remains, disable/uninstall Refined Wiki Theme and contact the plugin author for further assistance at:
1
2
support@refinedwiki.com
https://refinedwiki.atlassian.net/browse/RWOT
Was this helpful?